$re = '/(?<===)\s*\'(\S+?)\'/m';
$str = 'flag1 == \'hello\' and flag2==\'hello2\'';
$subst = "(\"$1\")";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;