const regex = /^(([^@]|[a-zA-Z\d.+ -]*)(?=@)@([a-zA-Z\d-]*)\.[a-zA-Z]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([^@]|[a-zA-Z\\d.+ -]*)(?=@)@([a-zA-Z\\d-]*)\\.[a-zA-Z]+)$', 'gm')
const str = `Valid email addresses
123@321.tld
prettyandsimple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-dash@example.com
x@example.com
"much.more unusual"@example.com
"very.unusual.@.unusual.com"@example.com
"very.(),:;<>[]\\".VERY.\\"very@\\\\ \\"very\\".unusual"@strange.example.com
example-indeed@strange-example.com
admin@mailserver1
#!\$%&'*+-/=?^_\`{}|~@example.org
"()<>[]:,;@\\\\\\"!#\$%&'-/=?^_\`{}| ~.a"@example.org
" "@example.org
example@localhost
example@s.solutions
user@localserver
user@tt
user@[IPv6:2001:DB8::1]
Invalid email addresses[edit]
saas@saas
123@321.345
Abc.example.com
A@b@c@example.com
a"b(c)d,e:f;g<h>i[j\\k]l@example.com
just"not"right@example.com
this is"not\\allowed@example.com
this\\ still\\"not\\\\allowed@example.com
john..doe@example.com
with caveat: Gmail lets this through, Email address#Local-part the dots altogether
john.doe@example..com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}