# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(([^@]|[a-zA-Z\d.+ -]*)(?=@)@([a-zA-Z\d-]*)\.[a-zA-Z]+)$"
test_str = ("Valid email addresses\n\n"
"123@321.tld\n\n"
"prettyandsimple@example.com\n"
"very.common@example.com\n"
"disposable.style.email.with+symbol@example.com\n"
"other.email-with-dash@example.com\n"
"x@example.com\n"
"\"much.more unusual\"@example.com\n"
"\"very.unusual.@.unusual.com\"@example.com\n"
"\"very.(),:;<>[]\\\".VERY.\\\"very@\\\\ \\\"very\\\".unusual\"@strange.example.com\n"
"example-indeed@strange-example.com\n"
"admin@mailserver1\n"
"#!$%&'*+-/=?^_`{}|~@example.org\n"
"\"()<>[]:,;@\\\\\\\"!#$%&'-/=?^_`{}| ~.a\"@example.org\n"
"\" \"@example.org\n"
"example@localhost\n"
"example@s.solutions\n"
"user@localserver\n"
"user@tt\n"
"user@[IPv6:2001:DB8::1]\n\n\n"
"Invalid email addresses[edit]\n"
"saas@saas\n"
"123@321.345\n"
"Abc.example.com\n"
"A@b@c@example.com\n"
"a\"b(c)d,e:f;g<h>i[j\\k]l@example.com\n"
"just\"not\"right@example.com\n"
"this is\"not\\allowed@example.com\n"
"this\\ still\\\"not\\\\allowed@example.com\n"
"john..doe@example.com\n"
"with caveat: Gmail lets this through, Email address#Local-part the dots altogether\n"
"john.doe@example..com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.