#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(" & @CRLF & _
" [A-Z][A-Z]\d\d[A-Z]\[" & @CRLF & _
" (\*" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" (" & @CRLF & _
" (\d|\d\d)-(\d|\d\d)" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (\d|\d\d)" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" \]" & @CRLF & _
" (,|$)" & @CRLF & _
")+"
Local $sString = "RA01D[1-1],RA01D[17-17],RA01D[2-2],RA01D[18-18]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")