using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(
[A-Z][A-Z]\d\d[A-Z]\[
(\*
|
(
(
(\d|\d\d)-(\d|\d\d)
)
|
(\d|\d\d)
)
)
\]
(,|$)
)+";
string input = @"RA01D[1-1],RA01D[17-17],RA01D[2-2],RA01D[18-18]";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}