package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(
[A-Z][A-Z]\d\d[A-Z]\[
(\*
|
(
(
(\d|\d\d)-(\d|\d\d)
)
|
(\d|\d\d)
)
)
\]
(,|$)
)+`)
var str = `RA01D[1-1],RA01D[17-17],RA01D[2-2],RA01D[18-18]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}