// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(
[A-Z][A-Z]\d\d[A-Z]\[
(\*
|
(
(
(\d|\d\d)-(\d|\d\d)
)
|
(\d|\d\d)
)
)
\]
(,|$)
)+").unwrap();
let string = "RA01D[1-1],RA01D[17-17],RA01D[2-2],RA01D[18-18]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}