const regex = /^([+]?39)?(3)(\d{8,9})$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([+]?39)?(3)(\\d{8,9})$', 'gmi')
const str = `123456
+39347123456
39347123456
393471234567
+393471234567
+3934712345678
347123456
3471234567
34712345678
393203394816
+393203394816
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}