# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)(\d)/$1 $2/gm;t' <<< "CB30QB
N12NL
CB249LQ
OX144FB
OX145FB"