const regex = /^(.*)(\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)(\\d)', 'gm')
const str = `CB30QB
N12NL
CB249LQ
OX144FB
OX145FB`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);