re = /^(.*)(\d)/m
str = 'CB30QB
N12NL
CB249LQ
OX144FB
OX145FB'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result