// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*)(\d)").unwrap();
let string = "CB30QB
N12NL
CB249LQ
OX144FB
OX145FB";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}