#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)CUT-FROM-.*CUT-TO"
Local $sString = "CUT-FROM-A ..." & @CRLF & _
"CUT-FROM-B ..." & @CRLF & _
"CUT-TO ..." & @CRLF & _
"CUT-TO" & @CRLF & _
"abc" & @CRLF & _
"CUT-FROM-C ..." & @CRLF & _
"CUT-TO" & @CRLF & _
"def" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")