re = /CUT-FROM-.*CUT-TO/
str = 'CUT-FROM-A ...
CUT-FROM-B ...
CUT-TO ...
CUT-TO
abc
CUT-FROM-C ...
CUT-TO
def
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end