#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*\bwww\.)https?:\/\/.*"
Local $sString = "http://www.example.org/" & @CRLF & _
"http://status.example.org/index.php?datacenter=1" & @CRLF & _
"https://status.example.org/index.php?datacenter=2" & @CRLF & _
"https://www.example.org/Insights" & @CRLF & _
"http://www.example.org/Careers/Job_Opportunities" & @CRLF & _
"http://www.example.org/Insights/Press-Releases"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)