re = /^(?!.*\bwww\.)https?:\/\/.*/m
str = 'http://www.example.org/
http://status.example.org/index.php?datacenter=1
https://status.example.org/index.php?datacenter=2
https://www.example.org/Insights
http://www.example.org/Careers/Job_Opportunities
http://www.example.org/Insights/Press-Releases'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result