using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\/)?span([^>]*)>";
string substitution = @"";
string input = @"<span style=""font-weight: bold;"" class=""Apple-style-span"">A</span>
<span id="">B</span>
<span>C</span>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}