$re = '/^(§§[0-9]+f{1,2}\.|§[0-9]+)Abs\.[0-9]+(Z[0-9]+|lit[a-z])(sublit[ivx]+)?[A-Z][A-Za-z]*$/m';
$str = '§16Abs.1litaStVO
§§79f.Abs.1Z1GTG
§§79ff.Abs.1Z1GTG
§16Abs.1litasublitiiFBG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);