re = /('[^'\\]*(?:\\.[^'\\]*)*')|\s*,\s*/m
str = '\'Hello world\',dude, \'Somethi\\\'ngs, never, turn and go, bye'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end