$re = '/([\p{Hiragana}\p{Katakana}\p{Han}]+)/u';
$str = '[DMSM-8433] 加護亜依 Kago Ai – 加護亜依 vs. FRIDAY';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);