import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(\\+)?(0|27)([5-9])([0-9])( )?([0-9]{3})( )?([0-9]{4})$";
        final String string = "+27827860965\n"
	 + "27827860965\n"
	 + "0827860965\n"
	 + "034567891\n"
	 + "082 786 0965\n"
	 + "+2782 786 0965\n"
	 + "2782 786 0965";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}