use strict;
my $str = '+27827860965
27827860965
0827860965
034567891
082 786 0965
+2782 786 0965
2782 786 0965';
my $regex = qr/^(\+)?(0|27)([5-9])([0-9])( )?([0-9]{3})( )?([0-9]{4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}