using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!fruits).*$|((?<count>\d{1,})\s(?<fruit>\w{1,}))";
string input = @"fruits 5 apples, 2 oranges, 3 bananas,
cars 3 toyota, 4 benz, 1 trabi
buses 3 toyota, 4 benz, 1 trabi
fruits 5 apples, 2 oranges, 3 bananas,";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}