import Foundation
let pattern = #"^(?!fruits).*$|((?<count>\d{1,})\s(?<fruit>\w{1,}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
fruits 5 apples, 2 oranges, 3 bananas,
cars 3 toyota, 4 benz, 1 trabi
buses 3 toyota, 4 benz, 1 trabi
fruits 5 apples, 2 oranges, 3 bananas,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)