use strict;
my $str = 'asdas asdsad [1234][asd asd] asdasd';
my $regex = qr/\[\d{1,4}\]\[[a-zA-Z ]+\]/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";