// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\[\d{1,4}\]\[[a-zA-Z ]+\]").unwrap();
let string = "asdas asdsad [1234][asd asd] asdasd";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}