const regex = /[“â€"]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[“â€"]', 'g')
const str = `“@joemcelderry91: I've woken up with the flu I think! :( gunna try and run it off haha!! X†get well soon joey :)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);