package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^A-Z]+$`)
var str = `http://www.example.com/thefolder
http://www.example.com/theDirectory
http://www.example.com/theFolder
http://www.example.com/ThefolDeR
http://www.example.com/THEFOLDER`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}