// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<li.*<input type="checkbox" >)(.*\n*.*)(</li>)"#).unwrap();
let string = "<li class=\"task-list-item\"><input type=\"checkbox\" > Der Unit-Test <code>contextMenuReplacesText</code> wurde auskommentiert um die ausführung zu verhindern. Dieser Test funktioniert in meiner Umgebung nicht wie erwachtet. (Tastatur Layout?, Aktivierte Sprache des Betriebsystems?)
Datei: <code>X:\\pdfsam\\pdfsam-fx\\src\\test\\java\\org\\pdfsam\\ui\\prefix\\PrefixFieldTest.java</code></li>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}