const regex = /(?m)^(?<TITLE>.*)\R+(?<url>(?:rtmp|http):\S*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^(?<TITLE>.*)\\R+(?<url>(?:rtmp|http):\\S*)', 'g')
const str = `All text has PHP_EOL at end of its line.
Some TITLE OF RTMP STREAM
rtmp://slww/best
Some simple text what not required to find
Another not required string line`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}