$re = '/(?m)^(?<TITLE>.*)\R+(?<url>(?:rtmp|http):\S*)/';
$str = 'All text has PHP_EOL at end of its line.
Some TITLE OF RTMP STREAM
rtmp://slww/best
Some simple text what not required to find
Another not required string line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);