import re
regex = re.compile(r"(?m)^(?<TITLE>.*)\R+(?<url>(?:rtmp|http):\S*)")
test_str = ("All text has PHP_EOL at end of its line.\n"
"Some TITLE OF RTMP STREAM\n"
"rtmp://slww/best\n"
"Some simple text what not required to find\n"
"Another not required string line")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")