# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'([^'\s]+)'/\1/g;t' <<< "Andrea's -Stays as is
Kids' - stays as is
'Kids' --> Kids
Ki'd's' --> Kids'"