import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'([^'\\s]+)'";
final String string = "Andrea's -Stays as is\n"
+ "Kids' - stays as is\n"
+ "'Kids' --> Kids\n"
+ "Ki'd's' --> Kids'";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}