use strict;
my $str = 'Andrea\'s -Stays as is
Kids\' - stays as is
\'Kids\' --> Kids
Ki\'d\'s\' --> Kids\'';
my $regex = qr/'([^'\s]+)'/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";