$re = '/\'([^\'\s]+)\'/';
$str = 'Andrea\'s -Stays as is
Kids\' - stays as is
\'Kids\' --> Kids
Ki\'d\'s\' --> Kids\'';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;