Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?:([0-2]?[1-9]):([0-5][0-9])(?: ?([ap]m?))?|([0-2]?[1-9])(?: ?([ap]m?)))
/
gi
Input 1
1
New
5am 5 pm 5:00am 4:20pm 2:20 AM 12:00 pm 12:00am 8:00 12:00 8pm 7:pm 5:00