import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\b(?<!\\.))(?:1?\\d?\\d|2[0-4]\\d|25[0-5])(?:\\.(?:1?\\d?\\d|2[0-4]\\d|25[0-5])){3}(?=$|[^\\w.])";
final String string = "My input string & constraints are as follows :\n\n"
+ " IPv4 Range : 0.0.0.0 to 255.255.255.255 55.123.99.988 256.1.1.1\n"
+ " IPv4 address may / may not be present in the string\n"
+ " Valid Examples : this is an ip & this is an ip 200.100.2.32\n"
+ " String may start with IPv4 address\n"
+ " Valid Examples :\n"
+ "200.100.2.32 is an ip | Output : ['200.100.2.32']\n"
+ " Invalid Examples :\n"
+ "200.100.2.32is an ip | Output : []\n"
+ " String may end with IPv4 address\n"
+ " Valid Examples : the ip is 200.100.2.32\n"
+ "Output : ['200.100.2.32']\n"
+ " Invalid Examples : the ip is200.100.2.32\n"
+ "Output : []\n"
+ " String may contain an IPv4 address in the middle, and if it does - there will a space before and after the IPv4 address.\n"
+ " Valid Examples : the ip is 200.100.2.32 and it is ipv4 | Output : ['200.100.2.32']\n"
+ " Valid Examples : the ip is 200.100.2.32and it is ipv4 | Output : []\n"
+ " Multiple IPs may be present in a single string\n"
+ " Valid Examples : 200.100.2.32 100.50.1.16 | Output : ['200.100.2.32', '100.50.1.16']\n"
+ " Invalid Examples : 200.100.2.32.100.50.1.16 | Output : []\n"
+ "10.151.0.0,8.8.8.8,127.0.0.1,10.51.0.0,10.151.1.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}