import Foundation
let pattern = #"(?:^|\b(?<!\.))(?:1?\d?\d|2[0-4]\d|25[0-5])(?:\.(?:1?\d?\d|2[0-4]\d|25[0-5])){3}(?=$|[^\w.])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
My input string & constraints are as follows :
IPv4 Range : 0.0.0.0 to 255.255.255.255 55.123.99.988 256.1.1.1
IPv4 address may / may not be present in the string
Valid Examples : this is an ip & this is an ip 200.100.2.32
String may start with IPv4 address
Valid Examples :
200.100.2.32 is an ip | Output : ['200.100.2.32']
Invalid Examples :
200.100.2.32is an ip | Output : []
String may end with IPv4 address
Valid Examples : the ip is 200.100.2.32
Output : ['200.100.2.32']
Invalid Examples : the ip is200.100.2.32
Output : []
String may contain an IPv4 address in the middle, and if it does - there will a space before and after the IPv4 address.
Valid Examples : the ip is 200.100.2.32 and it is ipv4 | Output : ['200.100.2.32']
Valid Examples : the ip is 200.100.2.32and it is ipv4 | Output : []
Multiple IPs may be present in a single string
Valid Examples : 200.100.2.32 100.50.1.16 | Output : ['200.100.2.32', '100.50.1.16']
Invalid Examples : 200.100.2.32.100.50.1.16 | Output : []
10.151.0.0,8.8.8.8,127.0.0.1,10.51.0.0,10.151.1.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)