#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([0-2][1-9]\.((0[1-9])|1[0-2]))|((3[0,1])\.((0[1,3-9])|(1[0-2]))))\.(\d{4})"
Local $sString = "11.01.2022" & @CRLF & _
"29.02.2022" & @CRLF & _
".02.2022" & @CRLF & _
"99.99.2022" & @CRLF & _
"31.01.2021" & @CRLF & _
"30.01.2021"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")