#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:[0-9]{12}|[0-9]{10}[A-Z])\b"
Local $sString = "4024204455A" & @CRLF & _
"192345006900" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4024204455A" & @CRLF & _
"192345006900" & @CRLF & _
"19234500690000000000" & @CRLF & _
"192345006900000A" & @CRLF & _
"" & @CRLF & _
"This is a test 4024204455A this is a test" & @CRLF & _
"4024204455A this is a test" & @CRLF & _
"this is a test 4024204455A" & @CRLF & _
"This is a test4024204455A this is a test" & @CRLF & _
"4024204455Athis is a test" & @CRLF & _
"this is a test4024204455A" & @CRLF & _
"This is a test,4024204455A this is a test" & @CRLF & _
":4024204455A: this is a test" & @CRLF & _
"this is a test##4024204455A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")