const regex = new RegExp('\\b(?:[0-9]{12}|[0-9]{10}[A-Z])\\b', 'g')
const str = `4024204455A
192345006900
4024204455A
192345006900
19234500690000000000
192345006900000A
This is a test 4024204455A this is a test
4024204455A this is a test
this is a test 4024204455A
This is a test4024204455A this is a test
4024204455Athis is a test
this is a test4024204455A
This is a test,4024204455A this is a test
:4024204455A: this is a test
this is a test##4024204455A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}