use strict;
my $str = '4024204455A
192345006900
4024204455A
192345006900
19234500690000000000
192345006900000A
This is a test 4024204455A this is a test
4024204455A this is a test
this is a test 4024204455A
This is a test4024204455A this is a test
4024204455Athis is a test
this is a test4024204455A
This is a test,4024204455A this is a test
:4024204455A: this is a test
this is a test##4024204455A';
my $regex = qr`\b(?:[0-9]{12}|[0-9]{10}[A-Z])\b`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}