$re = '`\b(?:[0-9]{12}|[0-9]{10}[A-Z])\b`';
$str = '4024204455A
192345006900
4024204455A
192345006900
19234500690000000000
192345006900000A
This is a test 4024204455A this is a test
4024204455A this is a test
this is a test 4024204455A
This is a test4024204455A this is a test
4024204455Athis is a test
this is a test4024204455A
This is a test,4024204455A this is a test
:4024204455A: this is a test
this is a test##4024204455A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);