using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<input.*orderId.*value=""(.*)""";
string input = @"<input id=""amount"" type=""hidden"" value=""105"">
<input id=""orderId"" type=""hidden"" value=""10000"">
<input id=""userId"" type=""hidden"" value=""200"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}