package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<input.*orderId.*value="(.*)"`)
var str = `<input id="amount" type="hidden" value="105">
<input id="orderId" type="hidden" value="10000">
<input id="userId" type="hidden" value="200">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}