import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<input.*orderId.*value=\"(.*)\"";
final String string = "<input id=\"amount\" type=\"hidden\" value=\"105\">\n"
+ "<input id=\"orderId\" type=\"hidden\" value=\"10000\">\n"
+ "<input id=\"userId\" type=\"hidden\" value=\"200\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}