re = /<input.*orderId.*value="(.*)"/
str = '<input id="amount" type="hidden" value="105">
<input id="orderId" type="hidden" value="10000">
<input id="userId" type="hidden" value="200">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end