// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|[^[:digit:]])[[:digit:]]{3}($|[^[:digit:]])").unwrap();
let string = "
.. 551 .. 552.. 553..
But i need to exclude from that the numbers
55341 55312 55227";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}