import Foundation
let pattern = ##".*(d|d[~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([a@4\p{L}\s]|[a@4\p{L}]e|[a@4\p{L}][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([s%5$]|[s5$]c|[s%5$][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s\p{L}]*)(h|h[~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)([i!1y|]|[i!1y|][~`!@#$%^&:;"'?|<>*\(\)\[\]\{\}\/\\+.,_\-\s]*)?[yie€3].*"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
123123213dashie214124124
Dashie
dashi3
d.ashie
da-shie
das"hie
dash$ie
dashi%e
dashie^
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)